Bug #22

X230 native raminit failed

Added by Patrick Rudolph over 3 years ago. Updated 3 months ago.

Status:Needs TestingStart date:01/10/2016
Priority:NormalDue date:
Assignee:Patrick Rudolph% Done:

0%

Category:-
Target version:-

Description

Native raminit failed with: "edge write discovery failed".
It's failing on channel 1 with two DIMMs installed, while it has no problems booting with a single DIMM.
The test fails on lane 1.
These are the Cvals of channel 1:
Cval: 1, 1, 0, 26
Cval: 1, 1, 1, 21
Cval: 1, 1, 2, 41
Cval: 1, 1, 3, 4d
Cval: 1, 1, 4, 4e
Cval: 1, 1, 5, 52
Cval: 1, 1, 6, 2c
Cval: 1, 1, 7, 5e

Cval: 1, 0, 0, 22
Cval: 1, 0, 1, 5e
Cval: 1, 0, 2, 3b
Cval: 1, 0, 3, 4a
Cval: 1, 0, 4, 4a
Cval: 1, 0, 5, 4c
Cval: 1, 0, 6, 29
Cval: 1, 0, 7, 5b

Values for the same lane are about the same (+- 6units), but only lane 1
shows a huge offset of 61.

x230_edge_write_discovery_failed.log Magnifier (911 KB) Patrick Rudolph, 01/10/2016 02:02 PM

debugboot1.txt Magnifier (61.7 KB) Martin Kepplinger, 07/05/2017 11:37 AM

History

#1 Updated by Patrick Rudolph over 3 years ago

By adding a simple check to timB discovery:

 FOR_ALL_LANES {
               if (((ctrl->timings[channel][slotrank].lanes[lane].timB & 0x3f) == 0x3e) ||
                       ((ctrl->timings[channel][slotrank].lanes[lane].timB & 0x3f) == 0x3f))
               ctrl->timings[channel][slotrank].lanes[lane].timB += 2;
 }

The issue is fixed for me.
This patch just covers the problem instead of fixing it.

#2 Updated by Patrick Rudolph over 3 years ago

  • Status changed from New to Closed

Should be fixed in latest git.
Needs tests on x230.

#3 Updated by Alexander Couzens over 3 years ago

  • Status changed from Closed to Needs Testing

#4 Updated by Martin Kepplinger about 2 years ago

Native ram init should really work, as I'm using 2 DIMMs and at least with ram init I don't have a problem.
I append a cdbmem log, with ram debug enabled, in case that helps.

#5 Updated by First name * Last name * about 1 year ago

Works on my X230.

#6 Updated by Patrick Rudolph 3 months ago

More raminit fixes landed in the meantime. Does it still happen?

#7 Updated by Martin Kepplinger 3 months ago

Haven't had issues with raminit in a long time on the X230.

Also available in: Atom PDF