Bug #110

x220: regression on some memory modules between 4.4 - 4.5

Added by Alexander Couzens almost 2 years ago. Updated over 1 year ago.

Status:ResolvedStart date:05/02/2017
Priority:NormalDue date:
Assignee:Patrick Rudolph% Done:

0%

Category:-
Target version:-

edge_discover_failed - without debug (5.15 KB) Alexander Couzens, 07/28/2017 12:03 AM

edge_discover_failed_with_debug_empty_line (47.2 KB) Alexander Couzens, 07/28/2017 12:13 AM

edge_discover_failed_with_debug (44.1 KB) Alexander Couzens, 07/28/2017 12:13 AM

History

#1 Updated by Patrick Rudolph almost 2 years ago

Need full raminit log.

#3 Updated by Nico Huber over 1 year ago

You could also bisect it. I suspect this one:

7bddd30e94 nb/intel/sandybridge/raminit: Allow 933Mhz on Lenovo devices

Though, that could just be because I never agreed to it (it might even not make a difference in your case depending on the used memory modules).

#4 Updated by Patrick Rudolph over 1 year ago

  • Status changed from New to Resolved

Fixed as of b794a69ce9b2cbb9d6565cf0f3ac609402ad680a.
nb/intel/sandybridge/raminit: Add Kconfig option for fuses

Add a new Kconfig option to ignore memory fuses that limit the
maximum DRAM frequency to be used. The option is disabled by
default and should only enabled by experienced users as it
might decrease system stability or prevent a successful RAM
training.

Remove conflicting devicetree settings.

Also available in: Atom PDF