Project

General

Profile

Actions

Bug #432

closed

t440p reboots on suspend

Added by Josh R over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
10/21/2022
Due date:
% Done:

0%

Estimated time:
Affected versions:
Needs backport to:
Affected hardware:
Lenovo ThinkPad T440p
Affected OS:
Ubuntu 22.04 (Pop OS)

Description

Per request, adding new ticket for an issue with my t440p where attempting to resume on suspend results in a reboot (or at least, not resuming from DRAM).

My t440p already has coreboot installed (via osbmk). Following instructions from issue #412, I have attempted the following:

sudo flashrom -p internal --ifd -i bios -w the_full_12MiB_osbmk.rom --noverify-all

...but that did not seem to do the trick (still "restarts" without resuming from RAM).

Note that I am using the "full" 12MB osbmk rom (not split by 4MiB and 8MiB, as that seemed intended for the hardware flashing instructions).

coreboot version looks like 4.15.204, and flashrom version 1.2-640.

If it helps, attached cbmem -1 output with a "normal boot" followed by a later resume from suspend (that resulted in a restart).

Thanks in advance. I guess you don't realize how much you use suspend until it doesn't work anymore :)


Files

Actions #1

Updated by Angel Pons over 1 year ago

  • Status changed from New to Response Needed
  • Affected hardware changed from Lenovo t440p to Lenovo ThinkPad T440p

Hi, osboot is not the same as coreboot. Have you asked the people responsible for osboot to provide support?

It would be great if you could test with upstream coreboot, to make sure the issue is in coreboot and not about something the osboot people did.

Actions #2

Updated by Angel Pons over 1 year ago

Hmmm, looks like the issue happens because the MRC cache

Actions #3

Updated by Angel Pons over 1 year ago

sigh where is the "Edit" button?

Looks like the issue happens because something is messed up with the "ROM size"...

flash size 0x2800000 bytes
SF: Detected 00 0000 with sector size 0x1000, total 0x2800000
SF size 0x2800000 does not correspond to CONFIG_ROM_SIZE 0xc00000!!

This seems like a bug in osboot.

Actions #4

Updated by Angel Pons over 1 year ago

Yes, it's definitely an osboot problem... Please report the issue to osboot folks, and point them to this ticket.

After grabbing the T440p IFD.bin that osboot uses and using util/ifdtool's -d option on it (after manually padding to 12 MiB; you can just use the osboot image you built), it's clear why coreboot thinks the flash chip is much larger...

  Component 2 Density:                 32MB
  Component 1 Density:                 8MB

Component 2 Density should be "4MB" (technically, 4 MiB) instead. No clue where the IFD.bin that osboot uses comes from, but it's broken. See attached log for the complete ifdtool -d output.

Actions #5

Updated by Josh R over 1 year ago

Angel Pons wrote in #note-4:

Yes, it's definitely an osboot problem... Please report the issue to osboot folks, and point them to this ticket.

After grabbing the T440p IFD.bin that osboot uses and using util/ifdtool's -d option on it (after manually padding to 12 MiB; you can just use the osboot image you built), it's clear why coreboot thinks the flash chip is much larger...

  Component 2 Density:                 32MB
  Component 1 Density:                 8MB

Component 2 Density should be "4MB" (technically, 4 MiB) instead. No clue where the IFD.bin that osboot uses comes from, but it's broken. See attached log for the complete ifdtool -d output.

I appreciate you looking into this. I have submitted an issue here: https://notabug.org/osboot/osbmk/issues/161

For what it's worth, there was some discussion here on using an extracted IFD from a Lenovo-provided archive: https://notabug.org/osboot/osbmk/issues/129

Actions #6

Updated by Martin Roth about 1 year ago

  • Status changed from Response Needed to Closed

Closing as not an issue in coreboot.

Actions

Also available in: Atom PDF