Bug #42

Commit 53c388fe6dfb4fc4ffcee6c58345d353c6ec33bf breaks coreboot for alix2d13

Added by Reto Rayen almost 3 years ago. Updated over 2 years ago.

Status:ClosedStart date:04/13/2016
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:build system
Target version:-

Description

Device Name: Alix 2d13
Build Options: As txt attachment
Coreboot revision: 53c388fe6dfb4fc4ffcee6c58345d353c6ec33bf

The commit 53c388fe6dfb4fc4ffcee6c58345d353c6ec33bf breaks to build a working coreboot rom for a "Pc Engines Alix2d13"

A history about the single builds can be found here: https://file.youngsolutions.ch/index.php/s/g2cixjqepvTwJhR

Thank you in advance guys

coreboot_build_options_for_alix2d3.txt Magnifier (15.2 KB) Reto Rayen, 04/13/2016 01:45 PM

History

#1 Updated by Martin Roth almost 3 years ago

This builds for me under origin/master from coreboot.org, using the following miniconfig, so I'm still not sure what the issue is.

This miniconfig was generated by saving the coreboot_build_options_for_alix2d3.txt to .config then running 'make savedefconfig'. I then removed CONFIG_PXE_*= and CONFIG_ANY_TOOLCHAIN=y

To turn this back into a full config, save it as .config, then run 'make olddefconfig'

CONFIG_LOCALVERSION="4.3"
# CONFIG_COMPRESS_RAMSTAGE is not set
CONFIG_FLASHMAP_OFFSET=0x400000
CONFIG_VENDOR_PCENGINES=y
CONFIG_BOARD_PCENGINES_ALIX2D=y
CONFIG_CONSOLE_SERIAL_38400=y

Reto, could you please describe a little more about the failure you're seeing.
- If it's a build failure, please attach build logs of the output of 'make V=1'. Also, please make sure that CONFIG_ANY_TOOLCHAIN is disabled.
- If it's a boot failure, please attach the boot log.

#2 Updated by Martin Roth almost 3 years ago

It was just pointed out to me that this is probably the same issue as bug #41.
https://ticket.coreboot.org/issues/41

That seems right - I'll work on a fix for 41, and re-address this issue if that fix doesn't work.

#3 Updated by Reto Rayen almost 3 years ago

Hi Martin

the first two patches didn't worked.

#4 Updated by Reto Rayen almost 3 years ago

Hi Martin

sorry it was just the first one. I saw now. That my git reset to the second was not successfull. It cannot switch to the second and third patch. Looks like they are not commited yet.

#5 Updated by Reto Rayen almost 3 years ago

Hi Martin

here the results for the first patch:

Boot: https://file.youngsolutions.ch/index.php/s/sIKdynfj5Agbepi
Build: https://file.youngsolutions.ch/index.php/s/i5D8r34n7YVQsxB

Thanks Martin.

#6 Updated by Martin Roth over 2 years ago

This should be fixed at this point.

Reto, could you retest with the latest origin/master?

Thanks.

#7 Updated by Reto Rayen over 2 years ago

Hi Martin

you all, are awesome. It's working again. Thank you for your help. I did used the same config file, including the vsa image and it works like a charm. I'll try now to bring the ipxe payload into the coreboot, as describer here: https://pelican.craoc.fr/coreboot.html#ipxe. But you can close this ticket now.

Thank you very much for your help.

I created the coreboot rom with the following commit: f4609f9abf23bb48963ee173d2e54e5e71e6b64d.

#8 Updated by Kyösti Mälkki over 2 years ago

  • % Done changed from 0 to 100
  • Status changed from New to Closed

Also available in: Atom PDF