Bug #145

Building vboot or its components on non-x86 fails

Added by Paul Menzel over 2 years ago. Updated 11 days ago.

Status:ResolvedStart date:10/23/2017
Priority:NormalDue date:
Assignee:Patrick Georgi% Done:

0%

Category:build system
Target version:-

Description

Building the board Google Elm on a ppc64le system fails with the error below. coreboot toolchain 1.50 from October 15th, 2017 is used.

    CC            gen/futility_cmds.o
make[1]: *** No rule to make target '/dev/shm/coreboot/build/util/futility/build/host/arch/ppc64le/lib/crossystem_arch.o', needed by '/dev/shm/coreboot/build/util/futility/build/libvboot_util.a'.  Stop.
util/futility/Makefile.inc:4: recipe for target 'build/util/futility/build/futility/futility' failed
make: *** [build/util/futility/build/futility/futility] Error 2

The problem is that ppc64le is not listed in 3rdparty/vboot/Makefile.


Related issues

Duplicated by coreboot - Bug #263: coreboot build failure on ARM device (due to vboot) Closed 06/18/2020

History

#1 Updated by Martin Roth over 2 years ago

  • Assignee changed from Martin Roth to Stefan Reinauer

#2 Updated by Patrick Georgi 26 days ago

  • Duplicated by Bug #263: coreboot build failure on ARM device (due to vboot) added

#3 Updated by Patrick Georgi 26 days ago

  • Assignee changed from Stefan Reinauer to Patrick Georgi
  • Category set to build system
  • Subject changed from Cross-building *futility* on ppc64le fails to Building vboot or its components on non-x86 fails

Similar issues also pop up when building on ARM, but it's all the same root cause. Will dig into it.

#4 Updated by Patrick Georgi 11 days ago

  • Status changed from New to Resolved

Also available in: Atom PDF