Bug #300

Error building coreboot for t440p

Added by wi be 7 months ago. Updated about 2 months ago.

Status:NewStart date:03/17/2021
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

GenFv: ERROR 3000: Invalid

the required fv image size 0x51e400 exceeds the set fv image size 0x3e0000

full error log:
https://termbin.com/t134

defconfig:
https://termbin.com/80qv

full config:
https://termbin.com/oovf

History

#1 Updated by Paul Menzel 7 months ago

This is a TianoCore issue. Please try a different payload as a workaround.

#2 Updated by wi be 7 months ago

~~
i have tried now selecting the tianocore edk2 build from coreboot.
which resulted in UefiPayloadPkgIa32x64.dsc not to be found in
./payloads/external/tianocore/tianocore/UefiPayloadPkg/.*

as soon as i reverted my configuration back to the original as stated above
the build worked.~~

it was a custom bootsplash img that exceeded the size limits

#3 Updated by Paul Menzel 7 months ago

How big is /tmp/build/t440p/splash/bootsplash.bmp?

#4 Updated by wi be 7 months ago

Paul Menzel wrote:

How big is /tmp/build/t440p/splash/bootsplash.bmp?

i am not sure, as i deleted it.

I managed to create a buildable splash image, as described in this
tutorial: https://www.garyhawkins.me.uk/custom-logo-on-uefi-boot-screen/

#5 Updated by Jamal Wright 7 months ago

You can make more space using ME cleaner. I left the FD unlocked and was able to flash an image that spans both chips. Maybe adding a bootsplash is what grew tianocore? My file was only 24kb.

The vendor bios will ignore the changed ME chip.

#6 Updated by Daniel Kulesz about 2 months ago

Did you try increasing the CBFS size? The default is pretty small and doesn't even fit GRUB.

I recommend trying to increase it to 0x2A0000 or 0x7A0000 and trying again.

Also available in: Atom PDF