Bug #223

Errors compiling: No Video on Thinkpad x220 with 4.10

Added by Vasile Dan 4 months ago.

Status:NewStart date:07/30/2019
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:chipset configuration
Target version:-

Description

I'm having trouble compiling the new version for the Thinkpad x220. At first it throws some warnings, which stop the compilation very early. If I disable -Werror (CONFIG_WARNINGS_ARE_ERRORS=n) it again stops at ramstage/mainboard/lenovo/x220/gma-mainboard.o
The only way it compiles is with CONFIG_WARNINGS_ARE_ERRORS=n and ALL video (GFX and VGA) disabled. I've flashed the no-video image on the laptop and it worked except video output, of course, i.e. it booted up Linux.
Previous version worked flawlessly for me.
I'm including the piped logs of my latest failed attempt to compile (newly git-cloned repo shortly before submitting this) with -Werror and without al well as my defconfig.

build_Werror.log Magnifier - CONFIG_WARNINGS_ARE_ERRORS=y (8.27 KB) Vasile Dan, 07/30/2019 08:39 AM

build_no-Werror.log Magnifier - CONFIG_WARNINGS_ARE_ERRORS=n (34.3 KB) Vasile Dan, 07/30/2019 08:39 AM

defconfig (882 Bytes) Vasile Dan, 07/30/2019 08:39 AM

Also available in: Atom PDF