Bug #159

ThinkPad X230: Internal panel not works under Windows10

Added by Jiaxun Yang over 1 year ago. Updated 12 months ago.

Status:NewStart date:02/15/2018
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

I'm running coreboot on X230 with dual OS : Windows10 and ArchLinux. ArchLinux works fine. When I boot Windows10, the boot splash appears normally. However, just before the login screen, the whole panel become black without backlight. But the screens plug on VGA of machine or HDMI on docker work normally. The windows just not recognize internal screen. I've tried to remove the Intel driver igdkmd64.sys from windows10. And then, with the generic PNP display driver, it works, nevertheless, windows only recognized the internal panel, all external screens aren't working,

To deal with that, I also tried to replace vbios dumped by another person ( https://github.com/merge/coreboot-x230 ), Load VBT dumped from vendor UEFI, switch payload (tried SeaBios Tianocore and GRUB).

Personally, I think the problem may cause by ACPI or load of vbios. I know it's hard to debug under windows. Now, I can reproduce this issue 100%, so just ask if you need any help on debugging.

Thanks.

History

#1 Updated by Jiaxun Yang over 1 year ago

This issue is tested on Coreboot v4.7 release and Coreboot commit 533ea7adb5.

#2 Updated by Sebastian McMillan 12 months ago

I can reproduce this issue as well. Does not matter which payload I use, and native graphics init and VGA init doesn't matter either.

Also available in: Atom PDF